PHP, which is an initialism for PHP: Hypertext Preprocessor, is amongst the most commonly used scripting languages available out there. Any website or Internet application built using PHP will run on a given web server on the condition that a PHP module is activated, which makes the language absolutely universal and it isn’t really all that surprising that there are a few million web servers that support it and hundreds of millions of PHP-powered sites hosted on them. PHP is preferred over HTML due to the fact that it permits you to build a dynamic website with loads of different features. A PHP-based social networking site, for instance, will serve different web content to each user although the URL will not change. In comparison, HTML sites are static and the page content can be updated only manually. Just like any other software, PHP has several versions and the version that was used whilst building a particular website must be available on the server in order for the site to run faultlessly.
PHP 4 and PHP 5 Support in Shared Hosting
Our shared hosting servers support several PHP versions, which suggests that your sites will run without any problem no matter if your PHP scripts are outdated. We recognize the fact that an old site does not always suggest a vulnerable one as you may have implemented lots of mods to its source code. This is why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can pick which version will be active for your web hosting account. The version can be changed with one single click of the mouse in your Hepsia hosting Control Panel and the update will take effect straight away. In case you want to run both older and newer scripts, there’s even an option to use a different PHP version for each domain name of yours simultaneously.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
We’re strong in our opinion that several years spent building a site should not be lost, which means that in case you purchase a semi-dedicated server from us, you’ll be able to use any script, no matter if it is old or new. In contrast to a lot of hosting suppliers, we support several different PHP versions on our leading-edge cloud platform – 4, 5.2, 5.3, 5.4 and 5.5. Not only will you be able to activate the needed version via your Hepsia Control Panel, but you will also have the opportunity to pick a different version for each website. This can be accomplished simply by adding an .htaccess file to the given site’s root directory. You can change the current version both for a single website and for the whole account and the change will be applied in only a few minutes. With our hosting services, you can be sure that you will never encounter any website incompatibility issues.